npm ERR! cb() never called! (on npm 1.4~)

If you are getting the bellow error on a recent version npm (1.4~)

npm ERR! cb() never called!  
npm ERR! not ok code 0  

Chances are you are facing this issue:

npm shrinkwrap install - npm ERR! cb() never called! (Linux / OS X) https://github.com/npm/npm/issues/5920

Unfortunently there is no fix avialable as of yet (29th Oct 2014). The only solution seems to be rolling back to a old version of npm unaffected by the bug.

1.3.24  

The above version is not affected. You can downgrade npm using it self :)

sudo npm install npm@1.3.24 -g  

Cheers!